Cabling for Remote Console (Out-of-Band) Connectivity (Step 3)

Important
The ISR 2901 Configuration script and specifications for the slot number for placement of modules must be exact. The script will fail if the specifications are not met.

Cisco ISR 2901 with HWIC-16A and 2 CAB-HD8ASYNC Terminal Server

  • One 16-Port Async HWIC
  • One 512MB DRAM
  • One 256MB Compact Flash
  • Two High Density 8-port EIA-232 Async Cable (“Octal Cables”)
  • One Eight port 10/100/1000 Ethernet switch interface card

2901

To install the Cisco 2901 Integrated Services Router (Terminal Server):

  1. Install the 16-port Async HWIC module on EHWIC slot 0 (the rightmost slot) of the ISR 2901.
  2. Install the 8-port Ethernet switch module on EHWIC slot 2 and 3 of router. This module occupies two slots.
  3. Mount the ISR 2901 with the modules in the rack and connect the two octal cables to the Async HWIC module.

Cabling for Remote Console (Out-of-Band) Connectivity (without 9332 Switches)

Connecting the ISR 2901 to the Cisco ASR1000 Series, Cisco Nexus 93180YC-EX switch console ports and management ports provides remote console connectivity for Metacloud Support. The required physical connections are illustrated below:

Out of Band Cabling

Connecting the C2901 Async Module

Two sets of octal cables connect the console ports of the Cisco ASR1000 Series routers and Cisco Nexus 93180YC-EX switches to the Cisco ISR 2901. There are 4 connections required for this setup; P1, P2, P3, and P4. These connections are at the bottom octal cable. Follow the instructions below to connect the consoles:

  1. Connect the octal cable to the Async module.
  2. Connect the cables to the following console ports:
    • P1—connect to the first ASR1000 Series router console port.
    • P2—connect to the second ASR1000 Series router console port.
    • P3—connect to the first Nexus 93180YC-EX switch console port.
    • P4—connect to the second Nexus 93180YC-EX switch console port.

    Async Module Cable

To connect the 2901 router:

  1. Connect Gigabit Ethernet G0/0 (RJ45) to an uplink to the Internet for out-of-band (OOB) access.
  2. Connect Gigabit Ethernet G0/1 (RJ45) to port 44 of the first 93180YC-EX switch.

To connect the 2901 Ethernet switch module:

The 8-port switch module is used to connect the management ports of the ASR1000 Series routers and Nexus 93180YC-EX switches.

  • P1—connect to the first ASR1000 Series router’s management port (G0).
  • P2—connect to the second ASR1000 Series router’s management port (G0).
  • P3—connect to the first Nexus 93180YC-EX switch’s management port (mgmt0).
  • P4—connect to the second Nexus 93180YC-EX switch’s management port (mgmt0).
  • P5—connect to port 44 of the second 93180YC-EX switch.

Cabling for Remote Console (Out-of-Band) Connectivity (with 9332PQ Switches)

Connecting the ISR 2901 to the Cisco 2960, Cisco ASR1000 Series, Cisco Nexus 9332PQ, and Cisco Nexus 93180YC-EX switch console ports and management ports provides remote console connectivity for Metacloud Support. The required physical connections are illustrated below:

Out of Band Cabling with 9332

Connecting the C2901 Async Module

Two sets of octal cables connect the console ports of the Cisco ASR1000 Series routers and Cisco Nexus 93180YC-EX switches to the Cisco ISR 2901. There are 9 connections required for this setup; P1 to P8 and P1 on the second octal cable. These connections are at the bottom octal cable. Follow the instructions below to connect the consoles:

  1. Connect the octal cable to the Async module.
  2. Connect the cables to the following console ports:
    • P1—connect to the first ASR1000 Series router console port.
    • P2—connect to the second ASR1000 Series router console port.
    • P3—connect to the first Nexus 9332PQ console port.
    • P4—connect to the second Nexus 9332PQ console port.
    • P5—connect to the 2960 console port.
    • P6—connect to the first Nexus 93180YC-EX switch console port.
    • P7—connect to the second Nexus 93180YC-EX switch console port.
    • P8—connect to the third Nexus 93180YC-EX switch console port.
    • P1—(second Async module)connect to the fourth Nexus 93180YC-EX switch console port.

    Async Module Cable

To connect the 2901 Router:

  1. Connect Gigabit Ethernet G0/0 (RJ45) to an uplink to the Internet for out-of-band (OOB) access.
  2. Connect Gigabit Ethernet G0/1 (RJ45) to port 48 of the 2960.

Connecting the 2960 Ethernet Switch Module

Connect the management ports of the ASR1000 Series routers, Nexus 9332PQ switches, and Nexus 93180YC-EX switches to the 2960.

  • 1—connect to the first ASR1000 Series router’s management port (G0).
  • 2—connect to the second ASR1000 Series router’s management port (G0).
  • 3—connect to the first Nexus 9332PQ router’s management port (G0).
  • 4—connect to the second Nexus 9332PQ router’s management port (G0).
  • 5—connect to the first Nexus 93180YC-EX switch’s management port (mgmt0).
  • 6—connect to second Nexus 93180YC-EX switch’s management port (mgmt0).
  • 7—connect to third Nexus 93180YC-EX switch’s management port (mgmt0).
  • 8—connect to the fourth Nexus 93180YC-EX switch’s management port (mgmt0).

To connect the 2960 to the Nexus 9332PQ switches:

  1. Connect port TE1/0/1 on the 2960 to port 25 on the first Nexus 9332PQ.
  2. Connect port TE1/0/2 on the 2960 to port 25 on the second Nexus 9332PQ.

Configuring and Establishing Remote Console Connectivity

The first-time configuration process involves gathering a few configuration details of the local network, inserting them into the configuration template provided, and using a computer connected to the console port of the Cisco ISR 2901 to apply the completed configuration. The initial bootstrap is a one-time, manual process. All future maintenances and upgrades will be done remotely by Metacloud Support as part of operating the service.

Required Network Information

You must provide the following network information to Metacloud Support to complete your installation:

  • A publicly-routable IP Address for the ISR2901 or a private address that you can translate to a public IP for the purposes for establishing a VPN connection (OOB_WAN_IP).
  • The gateway IP address (OOB_WAN_GW) on your device serves as a gateway for the above IP.

Running the Initial Configuration Template

Complete the configuration template during the initial turn-up on the ISR 2901 router. The initial password is changed by Metacloud Support once this setup is completed. The ISR 2901 router comes with a default username and password as cisco/cisco.

To run the configuration template:

  1. Log into the ISR 2901.
  2. Perform write erase and reload to boot up with a clean configuration.
  3. Select a temporary password and replace the TEMP_PASSWORD in the configuration with the new password. Provide this password to the Metacloud Support team so they can continue configuring the ISR 2901. After the ISR 2901 configuration has been completed, the Metacloud Support team updates the password to match current operating standards.
  4. Paste the following configuration with the actual IP info for OOB_WAN_IP and OOB_WAN_GW.
!
hostname c2901
!
enable secret <TEMP_PASSWORD>
!
ip cef
!
license boot module c2900 technology-package securityk9
!
!
username temp_admin privilege 15 secret <TEMP_PASSWORD>
!
no ip domain lookup
ip domain name metacloud.in
!
crypto key generate rsa general-keys modulus 1024
!
ip ssh version 2
!
vrf definition wan
!
address-family ipv4
exit-address-family
!
access-list 101 permit 208.90.61.128 0.0.0.63 any 
access-list 101 deny ip any any
!
interface GigabitEthernet0/0
 vrf forwarding wan
 ip address <OOB_WAN_IP>
 ip access-group 101 in
 no shut
!
ip route vrf wan 0.0.0.0 0.0.0.0 <OOB_WAN_GW>
!
line con 0
 exec-timeout 15 0
 logging synchronous
 login local
line 0/0/0 0/0/15
 session-timeout 30
 exec-timeout 30 0
 disconnect-character 126
 logging synchronous
 no exec
 transport input ssh
 transport output none
line vty 0 15
 exec-timeout 15 0
 login local
 transport input ssh
End

Applying the Configuration

Connect a computer’s USB port to the Cisco ISR 2901 console port via a Cisco console cable and a USB port adapter, and use a terminal application to access the console interface of the ISR 2901.

Configure the serial port settings as follows:

  • Bits per second—9600
  • Data bits—8
  • Parity—None
  • Stop bits—
  • Flow control—None

Verify successful configuration by pinging an IP address elsewhere on the Internet, such as 8.8.8.8. A successful attempt returns the following:

#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

If the configuration is unsuccessful, verify the information is obtained correctly or contact Metacloud Support for assistance.

Important
When you have completed these steps, see Connecting the UCS C220 Control Plane Servers (Step 4) to complete your installation.